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Export of 3D models and scenes from SketchUp to VideoCAD 
 
Version 2.5     Edition for VideoCAD4-VideoCAD9 
 
Starting from version 9.1 VideoCAD offers convenient direct import of 3D models without using 
SketchUP.  
You can import 3D models from files: *.dxf, *.3ds, *.ase (3D Studio max), *.dae, *.xml 
(Collada), *.obj, *.stl and more than twenty 3D formats. You can download 3D models in 
Collada format (*.dae) from free SketchUP 3D Warehouse library 
(https://3dwarehouse.sketchup.com/), use 3DS Max models from designer's libraries, 3D models 
from game model libraries, create 3D models in SketchUP, save them in *.dae and import in 
VideoCAD. 
 
See more: http://www.cctvcad.com/videocad_help/index.html?prim_import3dmodels.htm 
 
 
Any 3D models and scenes which can be opened in SketchUp can be added to the VideoCAD 
library. Lots of 3D models can be downloaded from Internet for free. 
https://3dwarehouse.sketchup.com/  
You can also create models and scenes in SketchUp yourself. 
 
To open and edit the 3D models, to create and publish your own 3D models you need SketchUp 
3D editor http://www.sketchup.com 
 
There are 2 versions of SketchUp: 
 the free version that allows to work with 3D models, create scenes, but does not allow 

exporting these models and scenes into other CAD formats. 
 the paid version SketchUp Pro, allowing to export models and scenes into other CAD 

formats and import 3D models from many CAD formats: AutoCAD (*.dxf, *.dwg), 3DS 
Files (*.3ds), COLLADA files (*.dae), DEM (*.dem, *.ddf), IFS files, Google Earth files. 

 

For importing 3D models from free online 3D Warehouse library to VideoCAD the free 
SketchUp version is suitable. 
 
But if you need to import your 3D models in AutoCAD formats (*.dxf, *.dwg), you will need a 
paid version. 
 
You can download free SketchUP Make here https://www.sketchup.com/download/all or here 
https://help.sketchup.com/en/article/60107. 
 

This manual presents a step-by-step description of insertion a new 3D model into the VideoCAD 
library.  
You don't have to be a proficient user of SketchUp provided you have a ready-made model. You 
might need supplemental information, though. 
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Order of work: 
 
1. Installing the VideoCAD plugin into SketchUp 
 
1.1 Download and install SketchUp http://www.sketchup.com 
You can download free SketchUP Make here https://www.sketchup.com/download/all or here 
https://help.sketchup.com/en/article/60107. 
 
1.2.1  For SketchUp 2016 and newer add the plugin as Extension.  
Select  Main menu of SketchUP>Window>Extension manager>Install extension 
Then open videocad.rbz from the files folder in this archive. 
 
1.2.2  For older SketchUp versions copy videocad.rbs script file from the files folder in this 
archive to / Plugins / folder in the installation directory of SketchUp. 
 
Default directories for installing plugins: 

C:\Users\YOUR USERNAME\AppData\Roaming\SketchUp\SketchUp [n]\SketchUp\Plugins 

SketchUp 2013: C:\Program Files\SketchUp\SketchUp [n]\Plugins. 

SketchUp 8 and older: C:\Program Files\Google\Google SketchUp [n]\Plugins. 

[n]- number of SketchUP version 

Please see the actual information of plugin/extension installation in the last SketchUP version on 
http://www.sketchup.com 
 
1.3 Restart SketchUp.   
 
In the main menu of SketchUp, Tools submenu, the 
new Export to VideoCAD item must appear. 
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2.  Searching a necessary 3D model in the 3D Warehouse 
 
2.1 Launch SketchUp.  
 
2.2 Choose in the SketchUp Main menu: File>New. A new clear file will be created.  
 
2.3 Choose in the SketchUp Main menu:  File>3D Warehouse>Get models. The 3D 
Warehouse site will be opened. 

  

To access to the library Internet connection is needed.  
If you cannot get access to the 3D Warehouse via SketchUP menu, please find and download any 
3D model from the 3D Warehouse directly https://3dwarehouse.sketchup.com/ 
Then open the downloaded 3D model file in SketchUP. 
 
2.4 Enter the name of an object whose model you are looking for (in English) into the search box 

and click Search . 
 
2.5  In the appeared list of 3D models, select the most appropriate model and click on it. 
 
In order to improve performance, it is recommended to choose a 3D model without excessive 
amount of detail with minimal amount of polygons, preferably without textures. 
 
2.6  In appeared page with the image of the model , click Download. 
 
When you are asked Load this directly into your SketchUp model? click Yes. 
 

 
 
2.7  The selected model will appear in the SketchUp window. Move the model to the origin of 
coordinates. 
 
Edit and scale the 3D model if necessary. See SketchUp documentation for detail. 
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3.  Export chosen 3D model into VideoCAD file format 
 

3.1   Select a model (models) on the scene if you don’t wish to export the scene as a whole. Use 

the Select   tool. 
 
3.2  Choose in the SketchUp Main menu:Tools>Export to VideoCAD. 
 
3.3 The Export options box will appear. 
 

In the Model ID box a random number will be generated. 
You can leave this number without changes. 
 

VideoCAD identifies 3D models only by ID, not by names. 
All models in VideoCAD must have different IDs. Models 
with equal IDs will lead to errors in displaying them. It is 
recommended to use ID not less than 100. 
 

Attention! If the 3D model is designed for VideoCAD7 or 
previous version of VideoCAD, then in the Opacity and 
Textures boxes NO must be selected, otherwise errors 
may occur when working with such model in 
VideoCAD7 or previous versions of VideoCAD. 
 
Select YES in the Textures box if you want to export the 3D model with textures (for 
VideoCAD8 and latest versions). 
 
Texture files will be saved into a folder <model name> _textures in the same directory where the 
file of the 3D model <model name>.vcm is saved. When you move the saved model file, the 
folder with textures must be transferred together with the main file. 
 
Select YES in the Opacity box if you want to export the 3D model with transparency elements  
(for VideoCAD8 and latest versions). 
 
In the Scale box, you can specify scale of exported 3D 
model. 
 
If your model is a car and you want it to be displayed 
with license plates – select YES in the License plates 
box. Having another model not a car leave NO in the 
License plates box. 
 

Click OK. 
 
3.4 If you have chosen YES in the License plates box 
then the License plate positions box will appear. If you 
have chosen NO then a dialog box of saving model will 
appear, see Step 3.5 
 

In the License plate positions box choose YES in the 
boxes:  

 At Front – to display the front license plate 
 At Back – to display the back license plate 

Insert coordinates of the front and back license plates 
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into X,Y,Z boxes in meters relative to the origin of coordinates in SketchUp. 
 

Perhaps you will need several attempts to select right positions of the License plates. 
 

 
 
 

Click OK. 
 
In VideoCAD9, in the 3D models window, Sizes tab, you can add license plates and set their 
location for already imported 3D models. 
 
3.5 In the vcm file location dialog, enter the file name with *.vcm extension and click Save.  
  

The path of saving must not contain non-latin characters, model’s 
filename must begin from a letter and must not contain spaces!  
 

The export operation can take some time depending on complexity of 
the model. 
 
When the operation will be finished, the Success! message will 
appear.   
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4. Installing the new model into VideoCAD 
 
Installation procedures of 3D models into VideoCAD8 and previous VideoCAD versions are 
different. Starting from VideoCAD8 the installation has become faster and more convenient. 
 
4.1 Installing the new model into VideoCAD8 and next versions 
 
4.1.1 In VideoCAD Main menu choose 3D models>Add 3D model.   
Open the obtained *.vcm. file. 
If the loading 3D model has textures, in the same directory where the *.vcm file is located, a 
folder with textures must be located. The folder must be named <model name> _textures. Plugin 
of export from SketchUP automatically creates the folder with textures in the save directory of 
the model. 
 
4.1.2 After opening the file, the 3D Models window will appear, the 3D model will be loaded in 
the window. Projection of the 3D model will be displayed in the 3D Models window. 
 
4.1.3 Stretch the 3D Models window to adjust resolution of the projection. 
To improve performance, it is recommended to set the minimum required resolution (minimum 
size of the 3D Models window). 
 
4.1.4 Then click on the Save projection button and close the 3D Models window. After this, the 
3D model will appear in the VideoCAD menus and can be placed in the Graphic area. 
For more details of the 3D Models window please see VideoCAD help system. 
 
4.2 Installing the new model into VideoCAD7 and older versions 
 
4.2.1 Copy the *.vcm file of your model to /Models/ folder in VideoCAD installation directory. 
 
4.2.2 Launch VideoCAD. The new model will appear in the Constractions>3D model menu. 
You can place it, and watch it through video cameras.  Though you will not have the image of 
the model in the Graphics window. It will look like a gray 
rectangle instead. 
 
4.2.3 Place the model and a camera next to it. Direct the 
camera downwards at the model. In 3D window main menu 
choose Image>Save as *.bmp and save the image into the 
file. 
 

The model image size in pixels must be minimum-acceptable 
not to slow-down redrawing speed.   
 
4.2.4 Open the obtained image in Paint or another graphics 
editor and cut it out exactly along the borders of 3D model 
projection. Fill the free gaps with Teal color (R=0 G=128 
B=128).  The Teal color will be transparent when displaying 
the model projections. 
 
4.2.5 Rename the *.bmp file with the same name as the 
*.vcm model file and copy it to /Models/ folder in 
VideoCAD installation directory. 
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4.2.6 If you are going to place model not only in the horizontal projection, but also in the vertical 
projection (it is possible since VideoCAD 6), then make side view image of the model in the 
same way as you have made the image of model view from above (items 4.1.3, 4.1.4).  
Rename the obtained *.bmp file with the same name as the *.vcm model file but with the '_v' 
ending and copy it to /Models/ folder in VideoCAD installation directory. 
 
4.2.7 Launch VideoCAD. The new model is ready for use. 
 
5. Artifacts of imported 3D models 
 
Some wrong details of 3D models are not visible in SketchUP, but show up after exporting as 
artifacts. 
The artifacts can be eliminated by examining the properties of incorrectly imported elements and 
then correcting them in SketchUP before exporting. With the help of SketchUP tools almost all 
3D models can be imported to VideoCAD. 
 
5.1 Many artifacts disappear if you explode the model before importing. 

5.1.1 Select the Select  tool. 
5.1.2 Select the model by capturing it by the selection frame. 
5.1.3 Right click on the model. In the pop-up menu, select Explode. 
5.1.4 Repeat 5.1.2 and 5.1.3 while the Explode item is available in the pop-up menu. 
 
5.2. Color distortion or “holes in the model” are corrected by assigning to the outer side of all 
faces the material with the desired color. If the color is already assigned to the outside face, try 
reassigning the color. Replace black color by gray. 
In some models, the inner side of faces looks outward. You can reverse the faces using the 
Reverse Faces tool. Instead of reversing faces, you can color both sides of polygons by the same 
color. 
 
5.3. If the top of the model is not directed upwards, then you need to rotate the model in 
SketchUP so that the blue axis is directed upwards of the model. It is recommended to rotate the 
model so that the green axis is pointing back to the model. 
 
5.4 “Spots” on transparent polygons disappear if each glass is combined into a separate group 
with the Make Group tool before exporting. 
 
5.5 Texture losses are caused by non-Latin characters in file names of textures, texture resolution 
is too high, or unreadable texture file formats. 
The resolution can be reduced in Paint. You can read unreadable graphic formats and convert 
them to jpg using the free Xnview program. After the conversion, you need to open the * .vcm 
file in a text editor and correct all old texture file names to new ones. 
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This manual is accompanied by the sample file motorcycle.skp and resulted files of the 
motorcicle model motorcycle.vcm, motorcycle.bmp, motorcycle_v.bmp. You can find these 
files in the files folder.  
 
Wishing you success in using VideoCAD! 
 
Please, do not hesitate to ask for more information and technical support support@cctvcad.com. 


